Lotus Elan

Enjoying my Lotus at last

PostPost by: pauljones » Fri Apr 20, 2018 10:26 am

Jon

No mate, not a clue.
Kick the tyres and light them fires...!!!!!!!
pauljones
Fourth Gear
Fourth Gear
 
Posts: 953
Joined: 09 Feb 2008
Location: Gosport sur la mer,South hants

PostPost by: JonB » Fri Apr 20, 2018 11:59 am

To be fair he does say "Winner, winner chicken dinner!"

He's an Aussie with some serious electronics experience and an amusing style:

https://youtu.be/6a-jcaTn170

;)

Anyway, sorry - off topic!
1973 Elan Plus 2S 130/5 - UK - Chassis 50/1115L
JonB
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1207
Joined: 14 Nov 2017
Location: South Coast, UK

PostPost by: pauljones » Fri Apr 20, 2018 12:06 pm

Well another great day.

Continued with the removal of the engine, nothing major actually just jacked her up and sprayed wd40 and oil on all the bolts i could see.

Plan is, undo exhaust manifold where it goes into 1, try to loosen/unstuck/remove all other exhaust fixings.

Take of alternator, its now resting on the chassis frame anyway.

Support engine sump on blocks

Support gearbox on blocks

Undo all other bolts from mounts and bell house.

Hit with big hammers, swear alot, blame it all on 1960's "technology", and hey presto, engine will be out.

Ive been under the car today and see the mounts are coming away from the metal so a new set will be on order.

Hopefully the sun will continue.

PS.
I understand as the engine comes out i will probably cry.
Kick the tyres and light them fires...!!!!!!!
pauljones
Fourth Gear
Fourth Gear
 
Posts: 953
Joined: 09 Feb 2008
Location: Gosport sur la mer,South hants

PostPost by: JonB » Fri Apr 20, 2018 12:20 pm

Don't worry Paul, we are all here for you. Personally I think you should come to Goodwood for a chat - even if only for an hour or so - and to recharge your enthusaism.
1973 Elan Plus 2S 130/5 - UK - Chassis 50/1115L
JonB
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1207
Joined: 14 Nov 2017
Location: South Coast, UK

PostPost by: pauljones » Sun Apr 22, 2018 4:48 pm

Found some spyder mounts today that i cleaned up years ago. (Along with a full set of spyder front arms)

Will these be ok to use on the standard chassis to mount the zetec?

If not ive been given direction to construct some.
Attachments
20180422_151632.jpg and
Kick the tyres and light them fires...!!!!!!!
pauljones
Fourth Gear
Fourth Gear
 
Posts: 953
Joined: 09 Feb 2008
Location: Gosport sur la mer,South hants

PostPost by: pauljones » Fri Jun 01, 2018 11:57 am

So a quick question or two to help with the zetec install

For the engine mounts, do i use Elan weber mounts as a standard pair, ie just buy a new set? £20 + vat from Sue, same as most web sources.

Second question.

For the intake manifold, im looking at one with a 5° up sweep to clear the inner wing, not a straight manifold. Any thoughts on this.

https://m.ebay.co.uk/itm/Ford-Zetec-Inl ... SwovNaPLx0

Regards

PS I think i will have this working for next years castle coombe meeting.
Kick the tyres and light them fires...!!!!!!!
pauljones
Fourth Gear
Fourth Gear
 
Posts: 953
Joined: 09 Feb 2008
Location: Gosport sur la mer,South hants
Previous

Total Online:

Users browsing this forum: No registered users and 10 guests