Lotus Elan

Horn fault on Elan SE4

PostPost by: keith stringer » Tue Mar 26, 2019 7:59 pm

Hi,
Since I fitted new bushes in my steering column I now have the horn sounding every time I turn the steering wheel. I have checked the centre horn push but looks ok, can't see an obviouse short. Has any one had this problem who can lead me in the right direction.
Regards
Keith
keith stringer
First Gear
First Gear
 
Posts: 15
Joined: 27 May 2017
Location: England

PostPost by: checkrail » Tue Mar 26, 2019 8:40 pm

I had this problem when I had a Triumph GT6 , if your SE4 has a collapsible steering column you need to slacken the clamping bolts under the dash and ease the steering wheel towards you, it doesn't take much.

I am 99% certain the Elans/+2 are the same. The column switchgear on my +2 is Triumph.

Don't forget to retighten the clamp! Regards John
checkrail
First Gear
First Gear
 
Posts: 36
Joined: 17 Oct 2018
Location: lincoln

PostPost by: keith stringer » Tue Mar 26, 2019 9:40 pm

Hi John,
Thanks for your quick reply, I didn't think mine had the collapsible column but I will check it out tomorrow.
Thank you.
keith stringer
First Gear
First Gear
 
Posts: 15
Joined: 27 May 2017
Location: England

PostPost by: keith stringer » Wed Mar 27, 2019 2:02 pm

Tried adjusting the column this morning and it seems to have done the trick. Many thanks.
Regards
Keith
keith stringer
First Gear
First Gear
 
Posts: 15
Joined: 27 May 2017
Location: England

Total Online:

Users browsing this forum: No registered users and 11 guests