Lotus Elan

Ignition electric guru help needed

PostPost by: Nickhad » Fri Jun 14, 2019 11:58 am

5ef6bed1-999f-47f6-8e3d-340d2b260459.jpeg and
Coil pic
Hi all , purchased a s3 which had the wires cut at the regulator and battery.
The car needs a full restoration but I was going to try and start the car.
Replaced the starter new battery.
The car spins over using the solenoid but no ignition or spark at the dizzy.
I have found what I believe to be a cut out switch ,it was two wires one from the dizzy & one connected to the + side of the coil.
I’ve taken that out and put the wire from the dizzy to the coil .
On the other side on the coil there seems to be two wires looks like one going to a suppressor with the other going to the chassis.
Any advise would be most welcome.
Regards
Nick
Nickhad
New-tral
 
Posts: 10
Joined: 01 Jun 2019
Location: Hertfordshire

PostPost by: Keith Scarfe » Fri Jun 14, 2019 1:01 pm

Depends if you car is +ve or -ve earth. If an old original S3 as you say I am guessing it is +ve earth. Mine was originally.
In this case your live wire (the white one) should go the the -ve on the coil along with the lead to the suppressor, whose case is bolted to the chassis. The +ve on the coil will then go to the dizzy points or elec ignition. There shouldn't be a wire connecting any of the coil terminals to the chassis, only maybe one connecting the case of the coil via its mounting bolt.

If the car is -ve earth the live (white) goes to the coil +ve and the dizzy to the -ve on the coil.

You mustn't have the radio suppressor on the dizzy points side of the coil as this will suppress your spark. It must be on the live side of the coil.
Keith Scarfe
Third Gear
Third Gear
 
Posts: 234
Joined: 10 May 2004
Location: Suffolk, UK

PostPost by: Nickhad » Mon Jun 17, 2019 11:28 am

Thanks for the info, I've now connected the wires around the regulater and now have an ignition and spark on the dizzy .
Problem I've got is the new starter is negative earth and I have fitted the battery this way also ,so I have put the white wire coming from the loom on the plus siide with the wire from the dizzy going to the negative,
Would this be ok just to try and start it once I've fitted the pump and carbs .
Regards
Nick
Nickhad
New-tral
 
Posts: 10
Joined: 01 Jun 2019
Location: Hertfordshire

Total Online:

Users browsing this forum: No registered users and 3 guests