Lotus Elan

New Battery For +2s130

PostPost by: chrishewett » Fri Apr 30, 2004 7:48 am

I have just got my +2 out of the garage with a view to finally finishing the restoration and making it a daily use car.
The first thing is the battery is dead. Any thoughts on the type and capacity of new battery I should buy? Or will anything do?
No doubt many more questions will follow!
Chris
chrishewett
Third Gear
Third Gear
 
Posts: 472
Joined: 06 Oct 2003
Location: Lincolnshire

PostPost by: steveww » Fri Apr 30, 2004 8:17 am

A battery will loose charge sitting on the bench for a period time. The battery might just need a charge. You can get a little tester to check the acid in the battery, some places will top up the acid for you.

Failing that buy a new battery. Not too sure about the capacity required but make sure you get one the right physical size as well.
User avatar
steveww
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1838
Joined: 18 Sep 2003
Location: Northamptonshire, England

PostPost by: 1964 S1 » Sat May 01, 2004 12:34 am

I agree, check the battery water level, add if necessary and see if it can be brought back to life with a long slow trickle charge, if it's ok, put it in a Corolla and buy a new one for the Lotus unless it's a quick starting one..... I have an Optima battery in mine, it's been there through three or four Ohio winters and still works fine, lottsa cranking power and was in the car when I bought it. Not sure which exact model it is, the car's not here. I'll email you.
1964 S1
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1496
Joined: 15 Sep 2003
Location: Hamilton County, Ohio

PostPost by: JACKJABBA » Sun May 02, 2004 3:16 pm

Replaced my battery the other month. Only problem I found was getting the correct type so that you could use the original mounting system. I tried charging the old battery, it would hold a charge but went flat when trying to start the engine from cold. The new battery has made a big difference to starting.
JACKJABBA
Second Gear
Second Gear
 
Posts: 84
Joined: 17 Sep 2003
Location: Middleton St George, Co. Durham

PostPost by: chrishewett » Sun May 02, 2004 6:19 pm

What should the original mounting system be? Mine just sits in the boot. Obviously I will have to do something about it as I am likely to tip it over when cornering.
Chris
chrishewett
Third Gear
Third Gear
 
Posts: 472
Joined: 06 Oct 2003
Location: Lincolnshire

PostPost by: 1964 S1 » Fri May 07, 2004 10:31 pm

The battery in my 69 +2 is the Optima 8000, 800 cold cranking amps which has gotten the job done a lot longer than I ever thought it would. I don't know how many years old it is but it's going strong. Made in the USA. It fits in the notch at the RF of my trunk/boot floor. Fits very snugly and I have immaturely never installed a hold down, figuring I'd have to flip the car to dislodge it but this thread has made me see the light. Mounting wise, I'll use a convential three piece unit, two threaded rods with J or T ends and an L bracket for the rear top edge of the battery. May have to strap between the T hooks underneath...
1964 S1
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1496
Joined: 15 Sep 2003
Location: Hamilton County, Ohio

Total Online:

Users browsing this forum: No registered users and 7 guests