Page 1 of 1

Engine or carb problem??!

PostPosted: Mon May 27, 2019 6:04 pm
by davie489
Hi guys

Hopefully someone can help.....
had and engine rebuild last year and have only done 1000miles . The engine was rebuilt and always had a problem with plugs sooting up even after engine rebuild. Since the rebuild I have had new twin Weber’s put on and have been set up beautifully but my heart sinks as still have the problem with the plugs sooting up!!
Was there something wrong with the rebuild? Maybe the head and valve seats?
Before I ring up the engine rebuilders is there something I’m missing??
Cheers

Re: Engine or carb problem??!

PostPosted: Mon May 27, 2019 6:17 pm
by Slowtus
If the carbs are indeed set up properly and have no maladjusted/sticking bits then I would go after the spark side to see if it is weak.

Re: Engine or carb problem??!

PostPosted: Mon May 27, 2019 6:54 pm
by Elseezed
Had the same problem, standard engine on Dellorto carbs. Tried to resolve myself, in the end took it to a rolling road. Turned out to be carbs needed setting up properly, i.e; not me :oops:
The exhaust gas analyser will show up the carb issues.

Re: Engine or carb problem??!

PostPosted: Tue May 28, 2019 1:22 pm
by rgh0
What plugs are you using? The standard carb setup on a twink is rich for maximum power and the standard plugs to cold unless your driving at 9/10 ths all the time. So sooting up plugs is typical unfortunately

You just need to do all of the following
1. lean out the tune
2. use hotter plugs
3. drive harder

cheers
Rohan