Lotus Elan

Speedometer +2

PostPost by: Elan1558 » Thu Aug 22, 2019 2:46 pm

Hello,

Does anyone have a spare working speedo ?

Travelling home from Cornwall my speedo needle was very erratic and then it dropped off.

Neil.
Elan1558
New-tral
 
Posts: 6
Joined: 14 Oct 2016
Location: West Country

PostPost by: JonB » Thu Aug 22, 2019 3:44 pm

Check the speedo cable first. Much much cheaper than a replacement speedo. The symptoms you describe are indicative of cable wear followed by breakage.
Late 1972 Elan Plus 2S 130/5 - UK - Unit 50/1115L
User avatar
JonB
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1658
Joined: 14 Nov 2017
Location: South Coast, UK

PostPost by: ericbushby » Fri Aug 23, 2019 8:35 am

Hi Neil.
By `dropped off` do you mean the pointer dropped off it`s shaft and is now lying at the bottom.
If so it is just a push fit onto a taper with no other fixing.
It has to be fitted in line with the calibration dot which is at about minus 5 MPH on the dial and then gently persuaded past the springy stop to zero.
If you mean it is intact but stays at zero, then follow Jon`s suggestion.
Tell us more.
Eric in Burnley
1967 S3SE DHC
ericbushby
Fourth Gear
Fourth Gear
 
Posts: 737
Joined: 13 Jun 2011
Location: east lancashire

PostPost by: JonB » Fri Aug 23, 2019 10:00 am

"very erratic"

Points clearly at the cable. Mine's the same at low speeds but clears up once you are above 20 mph. Good spot on the "dropped off" bit, Eric. I thought he meant "stayed at zero".
Late 1972 Elan Plus 2S 130/5 - UK - Unit 50/1115L
User avatar
JonB
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1658
Joined: 14 Nov 2017
Location: South Coast, UK

PostPost by: DJW » Fri Aug 23, 2019 11:13 am

Ah same here, needle bounces all over the place below 30 mph then is fine.
1970 Elan Plus 2 S
User avatar
DJW
Second Gear
Second Gear
 
Posts: 79
Joined: 15 Jul 2016
Location: Evesham, Worc

PostPost by: Elan1558 » Fri Aug 23, 2019 4:55 pm

The needle was moving from 0 - 140 and back very quickly with an accompanying screeching noise then the needle dropped off.

The cable turns almost 180 degrees in a small amount of space. Would this be the problem ?

I have fitted the Lotus 5 speed box so maybe the 4 speed cable has been fitted which I believe is shorter?

Will the speedo innards suffered any damage ?

N.
Elan1558
New-tral
 
Posts: 6
Joined: 14 Oct 2016
Location: West Country

PostPost by: Elan1558 » Fri Aug 23, 2019 6:40 pm

45c15968-a6b2-4e72-bf8a-a6762826fe0c.png and
Looks broken to me.
Elan1558
New-tral
 
Posts: 6
Joined: 14 Oct 2016
Location: West Country

PostPost by: Elan1558 » Fri Aug 23, 2019 6:44 pm

ef90f957-4a3c-45a3-9a80-95ab40147748.png and
?
Elan1558
New-tral
 
Posts: 6
Joined: 14 Oct 2016
Location: West Country

PostPost by: ericbushby » Fri Aug 23, 2019 8:10 pm

Hi Neil,
It looks broken to me as well. That pin which you can see projecting from the centre of the pointer is the shaft/spindle that the pointer is normally pushed on to.
It should be connected to the aluminium disc behind the dial.
I am not so familiar with the Plus two, but for the two seater Elan speedos are usually considered unobtainable.
I suggest you ring one of the repairers. I used Speedy cables once, but other repairers are available.
Best of luck
Eric
ericbushby
Fourth Gear
Fourth Gear
 
Posts: 737
Joined: 13 Jun 2011
Location: east lancashire

PostPost by: Elan1558 » Fri Aug 23, 2019 9:51 pm

Thanks for all your replies.
Elan1558
New-tral
 
Posts: 6
Joined: 14 Oct 2016
Location: West Country

Total Online:

Users browsing this forum: No registered users and 1 guest