Lotus Elan

Servo Non Return Valve Sticking

PostPost by: david.g.chapman » Tue Apr 16, 2019 12:22 pm

I have this problem now and again. the non return valve seems to get sticky after a few weeks driving, and needs a fair puff to release it. I also notice that the first time I try the servo after startup it does not always operate properly.

When I take the non return valve out and clean it with petrol the problem goes away.

It seems that unburnt fuel might be getting to it and gumming things up? Normally the non return valve is at a high point in the vacuum line and my valve is low, and close to the servo (the valve was rattling where it used to be). Could this be the issue?

Dave Chapman.
david.g.chapman
Fourth Gear
Fourth Gear
 
Posts: 685
Joined: 26 Nov 2003
Location: Writtle, Essex

PostPost by: terryp » Mon Jun 03, 2019 12:05 pm

David
Have a look at the angle you have the servo mounted and see if it is correct. From memory they have to point upwards at approx 25degrees
Terry
terryp
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1598
Joined: 29 Nov 2007

PostPost by: john.p.clegg » Mon Jun 03, 2019 1:09 pm

I think David is talking about the non-return valve not the reaction valve...

John :wink:
User avatar
john.p.clegg
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 5576
Joined: 21 Sep 2003
Location: Manchester

PostPost by: terryp » Mon Jun 03, 2019 1:16 pm

Oopsey :oops: :oops: :oops:

Terry
terryp
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1598
Joined: 29 Nov 2007

PostPost by: john.p.clegg » Mon Jun 03, 2019 2:30 pm

Dave
The servo works on Vacuum,meaning air is sucked from it,not sent to it , being replenished through the air valve,maybe it is time to relocate the one way valve a little higher and start looking for a service kit?

John :wink: ,
User avatar
john.p.clegg
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 5576
Joined: 21 Sep 2003
Location: Manchester

Total Online:

Users browsing this forum: No registered users and 6 guests