Lotus Elan

Heat problem

PostPost by: trarker » Wed Sep 14, 2005 4:11 pm

Hello
I'm the proud owner of a 73 +2S 130/5 for several years now. This winter I had the engine rebuilt and ever since i've noticed that the temperature gauge is constantly very high (between 90°-110°) whetter I'm driving or at a full stop.
It's could be a radiator problem, but before rebuild it I would appreciate any advice you may be able to provide. Is it a inherent problem whit the + 2 I never noticed
tanck you in advance for your consideration

Jerome
trarker
First Gear
First Gear
 
Posts: 23
Joined: 13 Apr 2004

PostPost by: Madbury » Wed Sep 14, 2005 4:43 pm

Depends what rad you have. If its one of the later square ones (should be on a 73) with the bolted on flanges then it's a bit pants. What you need is one of the earlier rectangular full width rads, recored. Or if you've got the cash splash out on an alloy full width jobbie TTR do them or there's a chap on ebay knocking them out at the moment.
User avatar
Madbury
First Gear
First Gear
 
Posts: 22
Joined: 05 Apr 2004
Location: Reading UK

PostPost by: david.g.chapman » Wed Sep 14, 2005 7:05 pm

I had an high speed overheating problem on my +2, also with the radiator with the flanges each side. This rad was originally used on the triumph spitfire, so it was a bit low on capacity.

I solved my problem by having this rad re-cored, with 3 rows instead of 2, and with the tubes spaced closer together at 10mm intervals. This cost me £120.

Now the temperature gauge stays at 85 degrees whatever I get up to!

Dave Chapman.
david.g.chapman
Fourth Gear
Fourth Gear
 
Posts: 669
Joined: 26 Nov 2003
Location: Writtle, Essex

PostPost by: types26/36 » Wed Sep 14, 2005 7:29 pm

Dont just assume its the radiator if it was O.K. before the rebuild, before you start on the cooling system make sure the gauge is reading correctly, electrical gauges/stabilizer can give inaccurate readings, also check the electric fan is blowing through the radiator and not sucking.
Brian
Brian
64 S2 Roadster
72 Sprint FHC
User avatar
types26/36
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 3582
Joined: 11 Sep 2003
Location: U.K.

PostPost by: Dag-Henning » Thu Sep 15, 2005 7:08 am

True ! Make sure your know the real water-temp before you start a big operation. One of those temp-meters you push into the steak in the owen does the trick ,( - and my wife never found out........ :lol: ) Then check the termostat, before opening your wallet......
Rgds Dag
User avatar
Dag-Henning
Third Gear
Third Gear
 
Posts: 461
Joined: 30 Sep 2004
Location: Oslo, Norway

PostPost by: trarker » Thu Sep 15, 2005 7:16 am

thanks a lot for your answers

I'm interested by the "full alloy rad" on ebay but it's a litlle bit expensive for the moment...
I'm going to check the electric fan and the gauge

Jerome
trarker
First Gear
First Gear
 
Posts: 23
Joined: 13 Apr 2004

PostPost by: trarker » Mon Sep 19, 2005 9:48 am

Hi,
somes news from my week end...

The fan is blowing... the gauge seems to be right...

The temperature was right as lons as I was driving..but at each stop the temp° increased...

I'm afraid, i'm going to replace my rad, it's a small one. Alloy rad (radiator expert) seems to be the right part but is too expensive for the moment...

small rad comes from triumph spitfire . the large one comes it from a Triumph reference?

Jérôme
Last edited by trarker on Mon Sep 19, 2005 1:56 pm, edited 1 time in total.
trarker
First Gear
First Gear
 
Posts: 23
Joined: 13 Apr 2004

PostPost by: M100 » Mon Sep 19, 2005 10:25 am

I'd give the cooling system a good flush out before replacing anything and then check the following.

Is the fan really blowing into the engine bay?

Is it rotating the right way and at a fast speed?

Has the right thermostat being fitted and does it work?

Are you sure your engine has not being built a bit tight?

What is the oil temp?

These cars have run for years on the original rads both large and small. They might be marginal for hot climates, competition or in heavy traffic but every where else they are more than sufficent.

Does the +2 have the baffle/blanking plate round the steering rack like the Elans have to direct air into the radiator?
User avatar
M100
Fourth Gear
Fourth Gear
 
Posts: 766
Joined: 16 Sep 2003
Location: Yorkshire

PostPost by: trarker » Mon Sep 19, 2005 11:37 am

I checked the fan saturday, it's bowling, it's a new spal electric fan.
My engine was rebuilt by a well known specialist, it's now a 1650cm3
This problem is unconfortable and dangerous for my engine, so I'm going to upgrade the cooling system
trarker
First Gear
First Gear
 
Posts: 23
Joined: 13 Apr 2004

PostPost by: Hamish Coutts » Mon Sep 19, 2005 9:59 pm

Jérôme,

I had a similar problem with my +2. The rad repair man said the core of my radiator was from a Triumph Herald 1200. Not really suitable for a twink!
We agreed to upgrade the core, using the original header and footer[?] tanks, so that I didn't need to modify the radiator mounts etc. The new core was for a Triumph 2.5 pi so we thought it would do the job.
New core looks great and all is in place. It's still two rows but the vertical tubes are much closer together, so there are lots more of them. It is fine in the normal British summer but I wouldn't like to use it in say, France on a hot sunny day, in traffic.
With the benefit of hindsight I would have used a more efficient core (if one could be had) or a larger radiator and taken the hit of modifying the rad mountings. On a hot day here, i.e. 26deg C (well, that's hot for here) the fan was cutting in just sitting for a few minutes at traffic lights. I have an 82deg C thermostat fitted.
I have also just rebuilt the engine with a new water pump etc., overhauled the fan and put un 'forlife' coolant, so everything should be at its optimum.

Hope this helps,

Hamish.
"One day I'll finish the restoration - honest, darling, just a few more years....."
User avatar
Hamish Coutts
Fourth Gear
Fourth Gear
 
Posts: 517
Joined: 29 Jun 2004
Location: Scotland.

PostPost by: Robbie693 » Tue Sep 20, 2005 10:37 am

Has anyone thought of checking the hoses? Particularly the bottom one; that bend it goes through is very tight and could be resticting flow if it's past it's best....
User avatar
Robbie693
Coveted Fifth Gear
Coveted Fifth Gear
 
Posts: 1610
Joined: 08 Oct 2003
Location: UK

PostPost by: trarker » Thu Sep 29, 2005 8:35 am

Hi
Thanks a lot for your advices.
I just found a "famous french radiator specialist" in my neighbourhood. I'm going to solve my problem (I hope..) by re-coring my rad, with 3 rows instead of 2.

Jérôme
trarker
First Gear
First Gear
 
Posts: 23
Joined: 13 Apr 2004

PostPost by: trarker » Fri Oct 28, 2005 7:30 am

Hi,
I was ready to solve my pb by re coring my rad, but with the famous "rad specialist" it'll cost approx 200£.. so the ebay solution (full alloy rad / 300£) seems to be a better way....
What do you think about that ?
Jérôme
trarker
First Gear
First Gear
 
Posts: 23
Joined: 13 Apr 2004

PostPost by: cliveyboy » Mon Oct 31, 2005 8:10 am

Jerome
If you go to the Elan section on the second page there is a whole discussion on radiators under "radiator question"

Clive
cliveyboy
Fourth Gear
Fourth Gear
 
Posts: 585
Joined: 22 Sep 2003
Location: Oxfordshire UK

Total Online:

Users browsing this forum: ericbushby and 6 guests